Playa del Carmen, Mexico's virtual guidebook written by locals
 

Go Back   www.Playa.info > General discussion > General - Playa del Carmen
FAQ Calendar Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools
Old 07-08-2017   #1 (permalink)
into ruins
 
Join Date: Apr 2007
Posts: 64
Izzi 50 Megas

Hi guys,

I am in urgent need of a faster Internet connection, right now using Telmex and the max. I can get in my neighbourhood is 10 Megas with 0.5 upload. I need more upload and the only alternative is Izzi. The 50 Mega plan, according to them, has 3 upload. I used Cablemas/Izzi years ago and it was pretty bad. So at one point I canceled it and only used Telmex, which was still a little better.
Anyway, now a few years later maybe something has changed for the better. Does anyone have any experience with Izzi?

Thanks so much

Steve
steve71 is offline   Reply With Quote
Old 07-08-2017   #2 (permalink)
life=playa
 
DrewJones's Avatar
 
Join Date: May 2015
Location: Playa del Carmen
Posts: 677
I had random VPN drops and with Izzi. About once and hour on average. Sometimes more, sometimes less.


I troubleshooted this thing for a long time. Different computers, different routers, different Internet connections around town. Always happened with Izzi, never happened with TelMex. No one at support was aware of what was causing it. Google said that certain ISPs have policies that caused these exact symptoms, so I suspect it's an Izzi thing.


Overall, the service was fine. So if you're needing a VPN, I'd just say spend some time on an Izzi connection and see if it works for you.


I've since switched to TelMex because of this specific issue.
DrewJones is offline   Reply With Quote
Old 07-09-2017   #3 (permalink)
into ruins
 
Join Date: Apr 2007
Posts: 64
Quote:
Originally Posted by DrewJones View Post
I had random VPN drops and with Izzi. About once and hour on average. Sometimes more, sometimes less.


I troubleshooted this thing for a long time. Different computers, different routers, different Internet connections around town. Always happened with Izzi, never happened with TelMex. No one at support was aware of what was causing it. Google said that certain ISPs have policies that caused these exact symptoms, so I suspect it's an Izzi thing.


Overall, the service was fine. So if you're needing a VPN, I'd just say spend some time on an Izzi connection and see if it works for you.


I've since switched to TelMex because of this specific issue.
Hi Drew,

Thanks for the info. No VPN needed,but my main interest is the upload speed, currently onlu getting 0.8 with Telmex and was hoping someone could give me any information about the upload speed on the Izzi 50 Megas subscribtion. The told me it'll be 3, but out of experience I am a bit sceptical.

Thanks
steve71 is offline   Reply With Quote
Old 09-09-2017   #4 (permalink)
playa maya guy

 
ryberg's Avatar
 
Join Date: Sep 2002
Location: Playa del Carmen
Posts: 29,363
We're looking at this same issue now (I mean getting an ISP, not the specific problem Drew mentioned having), so just wondering if there's anything new on the topic. Thanks in advance, if so.
ryberg is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 03:52 AM.


Powered by: vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.